No announcement yet.

(BUG) Watchtower: Restricted Area

  • Filter
  • Time
  • Show
Clear All
new posts

  • (BUG) Watchtower: Restricted Area

    I had already reported this bug on the website but i'm posting this again hoping to be noticed by the moderators so here it goes;

    I just got the ROB and the oath buff for additional efficiency and went to red lotus, I cannot enter the Watchtower under any conditions and it pisses me off since i really need to get in there before the buff expires. I tried to enter using my windwalker and it works fine (the ww doesn't even have the torch) but my moonlord could not. I tried to re-log and also restarted the game client however i still can't enter. Could somebody help me? Am i missing something? WTH. Pictures below

  • #2
    Just a simple question,can you enter lab 9 nest?if not you have to at least clear a lab 8 nest or lab 8 cloister training ground to able to enter restricted area which are lab 9 and lab 10 nest.

    please note oath buff or dragon buff don't work there.
    Last edited by atom100; 07-04-2020, 05:58 PM.


    • #3
      i haven't tried that yet i'm new to this game. Thank you very much. I'll make an update after trying a lab 9 nest.


      • atom100
        atom100 commented
        Editing a comment
        no need to clear lab 9 nest just lab 8 clear , you will be able to enter lab 9, the easiest is lab 8 cloister training ground.