Announcement

Collapse
No announcement yet.

"Unable to create d3d device?" + "Preinitializedevice failed"

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • "Unable to create d3d device?" + "Preinitializedevice failed"

    I'm using an ASUS laptop with GTX1080. Out of 10+ attempts, I've managed to get it to work ONCE - after installing an older Nvidia driver. However, DN was REALLY laggy and slow.

    I've tried a few other older Nvidia drivers which give the exact same results as the Title. Now I'm back to trying with the latest Nvidia drivers and the latest DN SEA patch.

    Using the same method I've installed DN SEA on 3 other computers with absolutely zero problems. Only my favorite laptop has an issue!

    Can anyone advise an alternative possibility? Thanks!

  • #2
    do you have updated everything on your laptop? Visual C++ Software? DirectX runtime? .NET Framework? maybe the game can't run for lack of any of these software that i mentioned
    Yung Venuz bless you

    Comment


    • funster
      funster commented
      Editing a comment
      Hi, thanks so much for the suggestions, and I did try all of it. Unfortunately it seems to make no difference. Same issues.

      I maintain my other PCs in a similar way and they installed perfectly fine.No need to fiddle with drivers or DX or .NET and it worked on the first try.

  • #3
    What driver are you using in the first place? Stock/generic driver straight from Nvidia or OEM drivers customized and optimized by ASUS for their laptops?

    For laptops, it's advisable to use OEM drivers as they include further OEM adjustments for their hardware compatibility. When Nvidia releases updated drivers, wait for your laptop's OEM to release their optimized driver based on latest stock release. Do not use stock drivers with laptops. I also did ran on an issue when I did it with my laptop in the past. This might be the case. If you haven't tried it yet, please do try.
    Last edited by MeshPolygon; 03-08-2019, 05:59 AM.

    ✾▬▬▬▬▬▬❀▬▬▬▬▬▬✾
    Wars Of Our Time (Dn Sea Forum History)ED 1:1 Inquire(SEA)Choco's Academic Fanart Gallery :3
    CC archived data(Internet Archive-Alexa crawl data 06/07/2017)

    MeshPoly#4609

    Comment


    • #4
      Thanks so much for your great suggestion. I am indeed using NVIDIA Generic drivers. I'll look it up and see if it helps. Will update again.

      Comment


      • #5
        Sadly, the specific Nvidia drivers for my ASUS Laptop did not do anything. I did a clean install with the drivers (as in wiped out the old drivers, NOT the OS), rebooted and got the same error and behavior. ARGHH

        Thanks for the suggestion.
        Last edited by funster; 03-12-2019, 09:09 PM.

        Comment


        • MeshPolygon
          MeshPolygon commented
          Editing a comment
          That's unfortunate. Sorry for my unhelpful comment.

        • MeshPolygon
          MeshPolygon commented
          Editing a comment
          One more thing, have you also tried running it in Windows XP SP2 compatibility mode?

      • #6
        That's a great idea. Unfortunately I tried it and both failed to work.

        Sigh, I was quite hopeful it at least had an impact. But nope, same error. Thanks for the suggestion.

        Comment

        Working...
        X